Project

General

Profile

Bug #2194

ant - method run not working

Added by Kleyson Rios over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
2013-05-28
Due date:
% Done:

0%


Description

I can do with success a full compile using the command:

ant -Dproject=saude -Denv=48_desenv dist-clean all

But when I try run the BI server using the command:

ant -Dproject=saude -Denv=48_desenv run

I get the following error:

[exec] org.springframework.beans.factory.BeanDefinitionStoreException: IOException parsing XML document from ServletContext resource [/pentaho-spring-beans.xml]; nested exception is java.io.FileNotFoundException: Could not open ServletContext resource [/pentaho-spring-beans.xml]

But the penthao-spring-beans.xml file exists:

bidesenv@timo:/opt/development/cbf/project-saude/solution$ ls la /opt/development/cbf/project-saude/solution/system/pentaho-spring-beans.xml
-rw-r--r-
1 bidesenv users 797 May 23 06:57 /opt/development/cbf/project-saude/solution/system/pentaho-spring-beans.xml

The full log

bidesenv@timo:/opt/development/cbf$ ant Dproject=saude -Denv=48_desenv run
Buildfile: /opt/development/cbf/build.xml
[echo] -------------------------------------------------------------

[echo] --------------------------------------------------------------
[echo] ------ CBF - Community Build Framework -------
[echo] ------ Version: 3.7 -------
[echo] ------ Author: Pedro Alves () -------
[echo] --------------------------------------------------------------
[echo] --------------------------------------------------------------
[echo]
[echo] SETTINGS:
[echo]
[echo] Project: saude
[echo] Environment: build-48_desenv.properties
[echo] Config File: project-saude/config/build-48_desenv.properties
[echo] Server: tomcat
[echo] --------------------------------------------------------------
[echo] --------------------------------------------------------------

run-tomcat:
[exec] Listening for transport dt_socket at address: 8765
[exec] May 27, 2013 6:50:00 AM org.apache.catalina.core.AprLifecycleListener init
[exec] INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
[exec] May 27, 2013 6:50:00 AM org.apache.coyote.AbstractProtocol init
[exec] INFO: Initializing ProtocolHandler ["http-bio-8080"]
[exec] May 27, 2013 6:50:00 AM org.apache.coyote.AbstractProtocol init
[exec] INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
[exec] May 27, 2013 6:50:00 AM org.apache.catalina.startup.Catalina load
[exec] INFO: Initialization processed in 413 ms
[exec] May 27, 2013 6:50:00 AM org.apache.catalina.core.StandardService startInternal
[exec] INFO: Starting service Catalina
[exec] May 27, 2013 6:50:00 AM org.apache.catalina.core.StandardEngine startInternal
[exec] INFO: Starting Servlet Engine: Apache Tomcat/7.0.40
[exec] May 27, 2013 6:50:00 AM org.apache.catalina.startup.HostConfig deployDirectory
[exec] INFO: Deploying web application directory /opt/development/cbf/target-dist/server/webapps/ROOT
[exec] May 27, 2013 6:50:18 AM org.apache.catalina.util.SessionIdGenerator createSecureRandom
[exec] INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [17,086] milliseconds.
[exec] May 27, 2013 6:50:18 AM org.apache.catalina.startup.HostConfig deployDirectory
[exec] INFO: Deploying web application directory /opt/development/cbf/target-dist/server/webapps/sw-style
[exec] May 27, 2013 6:50:18 AM org.apache.catalina.startup.HostConfig deployDirectory
[exec] INFO: Deploying web application directory /opt/development/cbf/target-dist/server/webapps/pentaho
[exec] May 27, 2013 6:50:18 AM org.apache.catalina.startup.SetContextPropertiesRule begin
[exec] WARNING: [SetContextPropertiesRule]{Context} Setting property 'docbase' to 'webapps/pentaho/' did not find a matching property.
[exec] May 27, 2013 6:50:21 AM org.apache.catalina.startup.ContextConfig validateSecurityRoles
[exec] INFO: WARNING: Security role name PENTAHO_ADMIN used in an <auth-constraint> without being defined in a <security-role>
[exec] May 27, 2013 6:50:21 AM org.apache.catalina.startup.TaglibUriRule body
[exec] INFO: TLD skipped. URI: http://java.sun.com/jstl/core is already defined
[exec] [Server@19b2ed5b]: [Thread[localhost-startStop-1,5,main]]: checkRunning(false) entered
[exec] [Server@19b2ed5b]: [Thread[localhost-startStop-1,5,main]]: checkRunning(false) exited
[exec] [Server@19b2ed5b]: Initiating startup sequence...
[exec] [Server@19b2ed5b]: Server socket opened successfully in 0 ms.
[exec] [Server@19b2ed5b]: [Thread[HSQLDB Server @19b2ed5b,5,main]]: Database [index=0db=file:../../data/hsqldb/sampledata, alias=sampledata] did not open: org.hsqldb.HsqlException: The database is already in use by another process: org.hsqldb.persist.NIOLockFile@1eec12fa[file =/opt/data/hsqldb/sampledata.lck, exists=false, locked=false, valid=false, fl =null]: java.io.FileNotFoundException: /opt/data/hsqldb/sampledata.lck (No such file or directory)
[exec] [Server@19b2ed5b]: [Thread[HSQLDB Server @19b2ed5b,5,main]]: Database [index=1db=file:../../data/hsqldb/hibernate, alias=hibernate] did not open: org.hsqldb.HsqlException: The database is already in use by another process: org.hsqldb.persist.NIOLockFile@ecc34c76[file =/opt/data/hsqldb/hibernate.lck, exists=false, locked=false, valid=false, fl =null]: java.io.FileNotFoundException: /opt/data/hsqldb/hibernate.lck (No such file or directory)
[exec] [Server@19b2ed5b]: Initiating shutdown sequence...
[exec] [Server@19b2ed5b]: Shutdown sequence completed in 1 ms.
[exec] [Server@19b2ed5b]: 2013-05-27 06:50:22.072 SHUTDOWN : System.exit() was not called
[exec] [Server@19b2ed5b]: [Thread[HSQLDB Server @19b2ed5b,5,main]]: Database [index=2db=file:../../data/hsqldb/quartz, alias=quartz] did not open: org.hsqldb.HsqlException: The database is already in use by another process: org.hsqldb.persist.NIOLockFile@13456f23[file =/opt/data/hsqldb/quartz.lck, exists=false, locked=false, valid=false, fl =null]: java.io.FileNotFoundException: /opt/data/hsqldb/quartz.lck (No such file or directory)06:50:22,107 ERROR [JNDIResourceProvider] error closing context
[exec] [Server@19b2ed5b]: [Thread[HSQLDB Server @19b2ed5b,5,main]]: run()/openDatabases():
[exec]
[exec] javax.naming.OperationNotSupportedException: Context is read only
[exec] at org.apache.naming.NamingContext.checkWritable(NamingContext.java:962)
[exec] at org.apache.naming.NamingContext.close(NamingContext.java:762)
[exec] at com.tonbeller.tbutils.res.JNDIResourceProvider.close(JNDIResourceProvider.java:68)
[exec] at com.tonbeller.tbutils.res.CompositeResourceProvider.close(CompositeResourceProvider.java:56)
[exec] at com.tonbeller.tbutils.res.ResourcesFactory.initialize(ResourcesFactory.java:163)
[exec] at com.tonbeller.tbutils.res.ResourcesFactory.<init>(ResourcesFactory.java:92)
[exec] at com.tonbeller.tbutils.res.ResourcesFactory.<clinit>(ResourcesFactory.java:89)
[exec] at com.tonbeller.tbutils.res.ResourcesFactoryContextListener.contextInitialized(ResourcesFactoryContextListener.java:23)
[exec] at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4887)
[exec] at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5381)
[exec] at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
[exec] at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
[exec] at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
[exec] at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:633)
[exec] at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1114)
[exec] at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1672)
[exec] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
[exec] at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
[exec] at java.util.concurrent.FutureTask.run(FutureTask.java:166)
[exec] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
[exec] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
[exec] at java.lang.Thread.run(Thread.java:722)
[exec] May 27, 2013 6:50:22 AM org.apache.catalina.core.StandardContext startInternal
[exec] SEVERE: Error listenerStart
[exec] May 27, 2013 6:50:22 AM org.apache.catalina.core.StandardContext startInternal
[exec] SEVERE: Context [/pentaho] startup failed due to previous errors
[exec] 06:50:22,199 ERROR [ContextLoader] Context initialization failed
[exec] org.springframework.beans.factory.BeanDefinitionStoreException: IOException parsing XML document from ServletContext resource [/pentaho-spring-beans.xml]; nested exception is java.io.FileNotFoundException: Could not open ServletContext resource [/pentaho-spring-beans.xml]
[exec] at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:349)
[exec] at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:310)
[exec] at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:143)
[exec] at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:178)
[exec] at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:149)
[exec] at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:124)
[exec] at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:92)
[exec] at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:123)
[exec] at org.springframework.context.support.AbstractApplicationContext.obtainFreshBeanFactory(AbstractApplicationContext.java:422)
[exec] at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:352)
[exec] at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:255)
[exec] at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:199)
[exec] at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:45)
[exec] at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4887)
[exec] at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5381)
[exec] at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
[exec] at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
[exec] at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
[exec] at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:633)
[exec] at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1114)
[exec] at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1672)
[exec] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
[exec] at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
[exec] at java.util.concurrent.FutureTask.run(FutureTask.java:166)
[exec] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
[exec] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
[exec] at java.lang.Thread.run(Thread.java:722)
[exec] Caused by: java.io.FileNotFoundException: Could not open ServletContext resource [/pentaho-spring-beans.xml]
[exec] at org.springframework.web.context.support.ServletContextResource.getInputStream(ServletContextResource.java:117)
[exec] at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:336)
[exec] ... 26 more
[exec] 06:50:22,207 ERROR [Logger] misc-org.pentaho.platform.web.http.context.SolutionContextListener: SolutionContextListener.ERROR_0001 - Solution path is invalid
[exec] May 27, 2013 6:50:22 AM org.apache.catalina.startup.HostConfig deployDirectory
[exec] INFO: Deploying web application directory /opt/development/cbf/target-dist/server/webapps/pentaho-style
[exec] May 27, 2013 6:50:22 AM org.apache.coyote.AbstractProtocol start
[exec] INFO: Starting ProtocolHandler ["http-bio-8080"]
[exec] May 27, 2013 6:50:22 AM org.apache.coyote.AbstractProtocol start
[exec] INFO: Starting ProtocolHandler ["ajp-bio-8009"]
[exec] May 27, 2013 6:50:22 AM org.apache.catalina.startup.Catalina start
[exec] INFO: Server startup in 21718 ms

History

#1 Updated by Pedro Vale over 5 years ago

it's trying to read pentaho-spring-beans.xml from the / folder.
It looks as if the solution folder is not being set correctly when building the platform.
What are the contents of your 48_desenv.properties ? Are you defining a correct solution.path property?

#2 Updated by Pedro Vale over 5 years ago

  • Status changed from New to Awaiting Feedback
  • Assignee set to Kleyson Rios

#3 Updated by Kleyson Rios over 5 years ago

I wasn't using web.xml from quick-start package, so my pentaho-solution couldn't be setted correctly.

It's working know.

Thanks.

#4 Updated by Pedro Vale about 5 years ago

  • Status changed from Awaiting Feedback to Closed

Also available in: Atom PDF